This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author jackjansen
Date 2005-11-24.23:26:33
SpamBayes Score
Marked as misclassified
Logged In: YES 

Well, as I commented on this patch and you quickly followed my suggestions I 
felt obliged to test your fix, but I'm not sure about the outcome.

I built a C++ extension on MacOSX 10.4, gcc 4, framework Python. The good 
news is that it worked fine, everything built and worked as before. BUT: both 
with and without your mods my C++ modules are compiled with "gcc", not "g
++" or "c++". Linking is done with "c++", in both cases. I looked at distutils 
and it seems that it could indeed be the case that CXX is only used for linking 
and never for compilation, but I'm not 100% sure.

Additionally, the Makefile has
CC=             gcc
CXX=            c++
which is technically fine on my machine (g++ == c++), but may not work 

Maybe someone who has a machine with both cc/c++ and gcc/g++ installed, 
and preferrably incompatible compilers, could give this patch a try too?
Date User Action Args
2007-08-23 15:44:11adminlinkissue1324762 messages
2007-08-23 15:44:11admincreate