This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author darrel.opry
Recipients darrel.opry, paul.moore, steve.dower, tim.golden, zach.ware
Date 2022-03-07.18:28:51
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
I created a virtual env on windows 11. 
When I run pip install -r "..."
I get the error 
C:\Users\dopry\src\Client\\django> pip install -r .\requirements_to_freeze.txt
Traceback (most recent call last):
  File "C:\Users\dopry\AppData\Local\Programs\Python\Python310\lib\", line 196, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "C:\Users\dopry\AppData\Local\Programs\Python\Python310\lib\", line 86, in _run_code
    exec(code, run_globals)
  File "C:\Users\dopry\src\Client\\django\venv310\Scripts\pip.exe\", line 4, in <module>
ModuleNotFoundError: No module named 'pip'

When I run get command to verify that the venv is activated I get

(venv310) PS C:\Users\dopry\src\Client\\django> Get-Command python

CommandType     Name                                               Version    Source
-----------     ----                                               -------    ------
Application     python.exe                                         3.10.21... C:\Users\dopry\src\Client\\django\venv310\Scripts\python.exe

When I update the `venv310\pyenv.cfg` and set `include-system-site-packages = true` to true, it was defaulted to false, it seems that I can pip install my requirements successfully. 

When I try to start my app though, the requirements are not found.
Date User Action Args
2022-03-07 18:28:51darrel.oprysetrecipients: + darrel.opry, paul.moore, tim.golden, zach.ware, steve.dower
2022-03-07 18:28:51darrel.oprysetmessageid: <>
2022-03-07 18:28:51darrel.oprylinkissue46950 messages
2022-03-07 18:28:51darrel.oprycreate