Author jack__d
Recipients jack__d
Date 2021-07-21.18:09:03
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1626890943.41.0.549645989366.issue44700@roundup.psfhosted.org>
In-reply-to
Content
I believe this is a problem with my machine because I've tried checking out to known good commits (which worked on my machine before) and have the same issue, but I've tried everything and don't really know what to do next. I'm hoping someone can help me, and who knows – maybe it is a bug!

This is the command that fails::

   gcc  -Wl,-stack_size,1000000  -framework CoreFoundation \
      -o Programs/_testembed Programs/_testembed.o libpython3.11d.a -ldl   \
      -framework CoreFoundation

The linker is ignoring `libpython3.11d.a`, providing the following warning::

   ignoring file libpython3.11d.a, building for macOS-arm64 but attempting to link with file 
   built for macOS-arm64

Of course, what follows is a ton of undefined symbol errors; no surprises there. I don't understand how to fix the error, why it is happening, or how this issue could have possibly cropped up overnight. These are the things I've tried to fix it:

1. Run autoconf to regenerate the configure script.
2. Delete everything. Reconfigure and rebuild from a clean slate.
3. Comment out `.zshenv`, `.zshrc`, and `.zprofile`
4. Try configuring and compiling on bash and sh instead of zsh
History
Date User Action Args
2021-07-21 18:09:03jack__dsetrecipients: + jack__d
2021-07-21 18:09:03jack__dsetmessageid: <1626890943.41.0.549645989366.issue44700@roundup.psfhosted.org>
2021-07-21 18:09:03jack__dlinkissue44700 messages
2021-07-21 18:09:03jack__dcreate