Author harlantc
Recipients Maxime Belanger, Mika_Hawkins, benoithudson, corona10, dirn, eamanu, erlendaasland, harlantc, indygreg, jmr, jreese, lawrence-danna-apple, mattip, maxbelanger, miss-islington, mistydemeo, ned.deily, nieder, python-dev, ronaldoussoren, skrah, vstinner
Date 2021-04-15.15:38:57
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1618501140.96.0.364798357402.issue41100@roundup.psfhosted.org>
In-reply-to
Content
Trying to build from source to Apple M1 Big Sur (macOS 11), and it's failing to compile the standard library extension modules. It seems to be that the .c files are not being located properly, but looking in Modules/ I can see all the required source files are there. attached is a typical build log, have tried a variety of options to no avail. Similar build configurations have worked for previous MacOS releases, which leads me to believe this is something else. I've searched fairly exhaustively for any information related to this and come up with nothing.
History
Date User Action Args
2021-04-15 15:39:01harlantcsetrecipients: + harlantc, ronaldoussoren, vstinner, ned.deily, skrah, jmr, jreese, python-dev, dirn, mattip, indygreg, Maxime Belanger, maxbelanger, eamanu, corona10, miss-islington, mistydemeo, erlendaasland, nieder, lawrence-danna-apple, Mika_Hawkins, benoithudson
2021-04-15 15:39:00harlantcsetmessageid: <1618501140.96.0.364798357402.issue41100@roundup.psfhosted.org>
2021-04-15 15:39:00harlantclinkissue41100 messages
2021-04-15 15:39:00harlantccreate