Author Michael.Felt
Recipients Michael.Felt, corona10, miss-islington, pablogsal, serhiy.storchaka, shihai1991, vstinner
Date 2020-11-26.09:00:30
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1606381231.82.0.74525155611.issue41625@roundup.psfhosted.org>
In-reply-to
Content
This is still broken.

Since this was included in master - the AIX buildbot is failing to compile (https://buildbot.python.org/all/#/builders/438/builds/391 and https://buildbot.python.org/all/#/builders/302/builds/377)

Strangely enough - the first bot continues to fail compile at the same location - while the second bot (running in a different environment) starting passing compile and all tests starting with https://buildbot.python.org/all/#/builders/302/builds/406.

Note: bot 1 is using what I call (personal opinion) a mixed environment with some libraries coming from OSS packages and some from IBM AIX. bot 2 - relies on IBM AIX libraries.

++++++
Note: manual build on same system as bot 1 using gcc - gives same error:

aixtools@gcc119:[/home/aixtools/cpython/cpython-master]make V=1
        gcc -pthread -c -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall  -O  -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -Werror=implicit-function-declaration -fvisibility=hidden  -I./Include/internal  -I. -I./Include    -DPy_BUILD_CORE  -DABIFLAGS='""'    -o Python/sysmodule.o ./Python/sysmodule.c
        gcc -pthread -c -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall  -O  -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -Werror=implicit-function-declaration -fvisibility=hidden  -I./Include/internal  -I. -I./Include    -DPy_BUILD_CORE -o Modules/config.o Modules/config.c
        gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall  -O  -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -Werror=implicit-function-declaration -fvisibility=hidden  -I./Include/internal  -I. -I./Include    -DPy_BUILD_CORE_BUILTIN  -DPy_BUILD_CORE_BUILTIN -I./Include/internal -c ./Modules/posixmodule.c -o Modules/posixmodule.o
./Modules/posixmodule.c: In function 'os_splice_impl':
./Modules/posixmodule.c:10429:15: error: implicit declaration of function 'splice'; did you mean 'plock'? [-Werror=implicit-function-declaration]
         ret = splice(src, p_offset_src, dst, p_offset_dst, count, flags);
               ^~~~~~
               plock
cc1: some warnings being treated as errors
make: 1254-004 The error code from the last command is 1.

* On same system, using xlc-v13, the build completes normally.
History
Date User Action Args
2020-11-26 09:00:31Michael.Feltsetrecipients: + Michael.Felt, vstinner, serhiy.storchaka, corona10, pablogsal, miss-islington, shihai1991
2020-11-26 09:00:31Michael.Feltsetmessageid: <1606381231.82.0.74525155611.issue41625@roundup.psfhosted.org>
2020-11-26 09:00:31Michael.Feltlinkissue41625 messages
2020-11-26 09:00:30Michael.Feltcreate