This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author Michael.Felt
Recipients David.Edelsohn, Michael.Felt, lemburg, mark.dickinson, rhettinger, stutzbach, vstinner
Date 2020-11-16.12:53:46
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
I have been experimenting with different hardware and AIX versions.

When building on AIX 5.3 - and the oldest libraries - test_math passes.

When I run the test on POWER8, using either xlc or gcc test_math fails with just one element of the test.

When I run the test on POWER6 I get many more errors - that I never had before. These are all after OS updates (I was not going to build for AIX 5.3 any more).

An idea I have now - that may explain the sudden change in behavior is if the libraries have been optimized to always use the DFP (decimal floating point) internally - for what, from the application perspective - is the normal - no HW acceleration for FP - interface.

I know there are ways to 'discover' this, but I'll need to write some tests so that I can see - if linking to different libraries actuates DFP performance counters yes and no.

At this point - this feels like the a potential explanation.
Date User Action Args
2020-11-16 12:53:46Michael.Feltsetrecipients: + Michael.Felt, lemburg, rhettinger, mark.dickinson, vstinner, stutzbach, David.Edelsohn
2020-11-16 12:53:46Michael.Feltsetmessageid: <>
2020-11-16 12:53:46Michael.Feltlinkissue42323 messages
2020-11-16 12:53:46Michael.Feltcreate