This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author shakir_juolay
Recipients shakir_juolay
Date 2020-11-06.09:46:36
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
I get the below message when I run Jupyter Lab

D:\Users\sjuolay>jupyter lab
[W 12:37:50.862 LabApp] Terminals not available (error was No module named 'winpty.cywinpty')
[I 12:37:51.170 LabApp] JupyterLab extension loaded from d:\users\sjuolay\documents\python\python39\lib\site-packages\jupyterlab
[I 12:37:51.171 LabApp] JupyterLab application directory is d:\users\sjuolay\documents\python\python39\share\jupyter\lab
[I 12:37:51.300 LabApp] Serving notebooks from local directory: D:\Users\sjuolay
[I 12:37:51.301 LabApp] Jupyter Notebook 6.1.4 is running at:
[I 12:37:51.301 LabApp] http://localhost:8888/?token=9a64c8f9a15b970ecc775090c4e5b8c90677f1456a83a932
[I 12:37:51.301 LabApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
[C 12:37:51.330 LabApp]

    To access the notebook, open this file in a browser:
    Or copy and paste one of these URLs:
[I 12:37:53.917 LabApp] Build is up to date

And when I run the below from Python IDLE I get

>>> import winpty
Traceback (most recent call last):
  File "<pyshell#0>", line 1, in <module>
    import winpty
  File "D:\Users\sjuolay\Documents\Python\Python39\lib\site-packages\winpty\", line 11, in <module>
    from .ptyprocess import PtyProcess
  File "D:\Users\sjuolay\Documents\Python\Python39\lib\site-packages\winpty\", line 21, in <module>
    from .winpty_wrapper import PTY, PY2
  File "D:\Users\sjuolay\Documents\Python\Python39\lib\site-packages\winpty\", line 12, in <module>
    from .cywinpty import Agent
ModuleNotFoundError: No module named 'winpty.cywinpty'

Software Details
Python 3.9.0 (tags/v3.9.0:9cf6752, Oct  5 2020, 15:34:40) [MSC v.1927 64 bit (AMD64)] on win32
Jupyter Lab 2.2.9
pywinpty 0.5.7

Any idea how much of an impact the error has on Jupyter Lab, since it is launched in browser? How to fix this?
Date User Action Args
2020-11-06 09:46:37shakir_juolaysetrecipients: + shakir_juolay
2020-11-06 09:46:37shakir_juolaysetmessageid: <>
2020-11-06 09:46:37shakir_juolaylinkissue42275 messages
2020-11-06 09:46:36shakir_juolaycreate