Author bugsrep
Recipients Vladyslav.Bondar, bugsrep, christian.heimes, skip.montanaro, taleinat, xtreak
Date 2020-09-21.02:44:47
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1600656287.57.0.975366251307.issue41561@roundup.psfhosted.org>
In-reply-to
Content
I added client_context.set_ciphers("@SECLEVEL=1:HIGH"), then added server_context.set_ciphers("@SECLEVEL=1:HIGH"). The test failed in both cases.

I did not have problem with python 3.7.x. in Ubuntu 18.04. I have just tried compiling 3.7.5 in Ubuntu 20.04 and test_ssl failed.

I also remember downloading openssl source code, compiling it, and using --with-openssl=DIR option with python 3.8.x in Ubuntu 20.04. I tried different versions of openssl (I did not edit any config files, just compiled) and test_ssl failed with all of them. Does it mean that Ubuntu's config files were still used even in this case?
History
Date User Action Args
2020-09-21 02:44:47bugsrepsetrecipients: + bugsrep, skip.montanaro, taleinat, christian.heimes, Vladyslav.Bondar, xtreak
2020-09-21 02:44:47bugsrepsetmessageid: <1600656287.57.0.975366251307.issue41561@roundup.psfhosted.org>
2020-09-21 02:44:47bugsreplinkissue41561 messages
2020-09-21 02:44:47bugsrepcreate