Author christian.heimes
Recipients Vladyslav.Bondar, bugsrep, christian.heimes, skip.montanaro, taleinat, xtreak
Date 2020-09-20.17:02:11
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1600621331.55.0.902393469512.issue41561@roundup.psfhosted.org>
In-reply-to
Content
Four times 'True' means that OpenSSL is compiled with TLS 1.0, 1,1, 1.2, and 1.3 support. SSLContext().minium_version == MINIMUM_SUPPORTED and maximum_version == MAXIMUM_SUPPORTED mean that no crypto policy setting or OpenSSL security level setting has modified the minimum and maximum version. TLS 1.0 and 1.1 connection should work.

But it's not working for you and some connection are even failing "internal error". This smells like a Debian/Ubuntu have patched OpenSSL with a buggy patch that breaks OpenSSL's internal API.
History
Date User Action Args
2020-09-20 17:02:11christian.heimessetrecipients: + christian.heimes, skip.montanaro, taleinat, Vladyslav.Bondar, xtreak, bugsrep
2020-09-20 17:02:11christian.heimessetmessageid: <1600621331.55.0.902393469512.issue41561@roundup.psfhosted.org>
2020-09-20 17:02:11christian.heimeslinkissue41561 messages
2020-09-20 17:02:11christian.heimescreate