Author skrah
Recipients Anthony Sottile, christian.heimes, doko, lukasz.langa, mark.dickinson, miss-islington, pitrou, rhettinger, skrah
Date 2020-07-04.23:44:05
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1593906246.1.0.151189043893.issue40874@roundup.psfhosted.org>
In-reply-to
Content
> In any case, I would have had a hard time giving a competent opinion on this issue.

Essentially it's a really simple Linux packaging issue for the
external libmpdec.  To have the exact same behavior for the external
libmpdec as for the included libmpdec, packagers must use:

  3.8  <--> 2.4.2
  3.9  <--> 2.5.0


ArchLinux had no problems.  Debian, and by extension Ubuntu, requires
3.8 and 3.9 to be on the same system during a transitional period, as
pointed out in msg372928 (which is really the most important message
of this whole thread).  

The commit that pinned _decimal to libmpdec version 2.5.0 broke this
use case, but there are workarounds.


My stance is that it is important that libmpdec is pinned so distros
don't use a divergent version.  Since there are multiple mitigations
for Debian, I don't feel particularly guilty.


Review of the commit that pinned 2.5.0 would have led to the exact
same outcome: I would have pointed that out on GitHub.

Note that with the Debian scheme there is never a good time to
update libmpdec, regardless of the release cycle.
History
Date User Action Args
2020-07-04 23:44:06skrahsetrecipients: + skrah, rhettinger, doko, mark.dickinson, pitrou, christian.heimes, lukasz.langa, Anthony Sottile, miss-islington
2020-07-04 23:44:06skrahsetmessageid: <1593906246.1.0.151189043893.issue40874@roundup.psfhosted.org>
2020-07-04 23:44:06skrahlinkissue40874 messages
2020-07-04 23:44:05skrahcreate