Author andrewfg1992
Recipients andrewfg1992, ned.deily
Date 2020-06-29.17:48:44
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1593452924.87.0.341187003391.issue41129@roundup.psfhosted.org>
In-reply-to
Content
Thanks for your reply Ned.

I think you are right about mac OS sandboxes messing something up. Python builds most of the extension modules fine if I do a straightforward build in the /tmp directory like you said.

Do you know of any easy ways to disable mac OS sandboxes from being used in the python build from the command line? Alternatively, how do I open the python project in xcode11 GUI? I think I might be able to disable sandboxes from there. If you are not very familiar with mac OS sandboxes like me, feel free to leave that up to me to figure out.

Regarding you question about my command line tools version:

I upgraded the my xcode command line tools installation to 11.4 - I believe this is the latest version that's supported on mac 10.15.1

I still get the same error behavior though when building outside of /tmp.

In this case, here is the compiler that's getting used.

% gcc --version
Configured with: --prefix=/Library/Developer/CommandLineTools/usr --with-gxx-include-dir=/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/include/c++/4.2.1
Apple clang version 11.0.3 (clang-1103.0.32.29)
Target: x86_64-apple-darwin19.3.0
Thread model: posix
InstalledDir: /Library/Developer/CommandLineTools/usr/bin
History
Date User Action Args
2020-06-29 17:48:44andrewfg1992setrecipients: + andrewfg1992, ned.deily
2020-06-29 17:48:44andrewfg1992setmessageid: <1593452924.87.0.341187003391.issue41129@roundup.psfhosted.org>
2020-06-29 17:48:44andrewfg1992linkissue41129 messages
2020-06-29 17:48:44andrewfg1992create