Author pablogsal
Recipients Jim Fasarakis-Hilliard, Zahari.Dim, belopolsky, christian.heimes, eric.smith, gaborjbernat, gdr@garethrees.org, lukasz.langa, maresb, martin.panter, orsenthil, pablogsal, remi.lapeyre, rhettinger, terry.reedy, tim.peters, tshepang, vstinner, wim.glenn
Date 2020-05-31.21:18:08
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1590959888.55.0.438307491416.issue17005@roundup.psfhosted.org>
In-reply-to
Content
> The downside I see with any graph prefixed names is the fact that it implies a larger collection of graph operations.

I don't see that an issue. In the general term is better to have a general name and discuss further improvements than just name the module "topological_sort" and now being cornered if we ever want to add new graph-related stuff.

We can always say "no" to new functionality but changing the name of the module is not possible once is released.
History
Date User Action Args
2020-05-31 21:18:08pablogsalsetrecipients: + pablogsal, tim.peters, rhettinger, terry.reedy, belopolsky, orsenthil, vstinner, eric.smith, christian.heimes, lukasz.langa, tshepang, gdr@garethrees.org, martin.panter, wim.glenn, Zahari.Dim, Jim Fasarakis-Hilliard, remi.lapeyre, gaborjbernat, maresb
2020-05-31 21:18:08pablogsalsetmessageid: <1590959888.55.0.438307491416.issue17005@roundup.psfhosted.org>
2020-05-31 21:18:08pablogsallinkissue17005 messages
2020-05-31 21:18:08pablogsalcreate