Author ronaldoussoren
Recipients Dima.Tisnek, Mariatta, ned.deily, njs, ronaldoussoren
Date 2020-04-06.12:28:18
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1586176098.12.0.545528456279.issue40060@roundup.psfhosted.org>
In-reply-to
Content
AFAIK the macOS builds are still build on the oldest macOS release supported by the installer (that is, a macOS 10.9 system). This means the build won't use macOS APIs introduced in macOS 10.10 or later.

----

It would be nice to build the installer using the latest compiler and SDK (more APIs available, better compiler, ...), but that requires work to explicitly avoid using APIs that aren't available on the system the binary is running on.
History
Date User Action Args
2020-04-06 12:28:18ronaldoussorensetrecipients: + ronaldoussoren, ned.deily, njs, Dima.Tisnek, Mariatta
2020-04-06 12:28:18ronaldoussorensetmessageid: <1586176098.12.0.545528456279.issue40060@roundup.psfhosted.org>
2020-04-06 12:28:18ronaldoussorenlinkissue40060 messages
2020-04-06 12:28:18ronaldoussorencreate