Author cehovski
Recipients cehovski
Date 2020-01-21.12:53:42
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1579611222.47.0.288920213647.issue39410@roundup.psfhosted.org>
In-reply-to
Content
While trying to build Python 3.8.1 from source with Sqlite 3.30.1 on a CentOS 6.10 I get the following warning:

*** WARNING: renaming "_sqlite3" since importing it failed: build/lib.linux-x86_64-3.8/_sqlite3.cpython-38-x86_64-linux-gnu.so: undefined symbol: sqlite3_close_v2

The following modules found by detect_modules() in setup.py, have been
built by the Makefile instead, as configured by the Setup files:
_abc                  atexit                pwd
time


Failed to build these modules:
_uuid


Following modules built successfully but were removed because they could not be imported:
_sqlite3

If I try to import sqlite in python:
[vagrant@centos6 Python-3.8.1]$ ./python
Python 3.8.1 (default, Jan 21 2020, 04:22:59)
[GCC 4.4.7 20120313 (Red Hat 4.4.7-23)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import sqlite3
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/src/Python-3.8.1/Lib/sqlite3/__init__.py", line 23, in <module>
    from sqlite3.dbapi2 import *
  File "/usr/local/src/Python-3.8.1/Lib/sqlite3/dbapi2.py", line 27, in <module>
    from _sqlite3 import *
ModuleNotFoundError: No module named '_sqlite3'
>>>

Also tried building with SQLite version 3.7.9 from atomic repository with same error.
History
Date User Action Args
2020-01-21 12:53:42cehovskisetrecipients: + cehovski
2020-01-21 12:53:42cehovskisetmessageid: <1579611222.47.0.288920213647.issue39410@roundup.psfhosted.org>
2020-01-21 12:53:42cehovskilinkissue39410 messages
2020-01-21 12:53:42cehovskicreate