This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author joahking
Recipients Phillip Middleton, bkline, cayman, chris.jerdonek, christian.heimes, cjflory, cstratak, fthommen, hairygristle, joahking, kscheidegger, malektronic,
Date 2019-12-16.13:17:09
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
I ran over this same problem on Ubuntu 14.04

As per

"Python 3.7.0 will not compile on RHEL6 because it requires OpenSSL 1.0.2 or 1.1 and RHEL6 provides 1.0.1e"

openssl version confirms this to be the case on Ubuntu 14.04

"On Ubuntu 14.04 on Dreamhost, an extra flag is required for Python 3.7+:
First, follow these instructions:"

then I ran: 
./configure --with-ensurepip=yes CFLAGS="-I$HOME/openssl/include" LDFLAGS="-L$HOME/openssl/lib"

after that python3.7 was correct

hope that helps, kind regards
Date User Action Args
2019-12-16 13:17:10joahkingsetrecipients: + joahking, christian.heimes, bkline, chris.jerdonek, cstratak, hairygristle,, fthommen, kscheidegger, Phillip Middleton, cayman, malektronic, cjflory
2019-12-16 13:17:10joahkingsetmessageid: <>
2019-12-16 13:17:10joahkinglinkissue34028 messages
2019-12-16 13:17:09joahkingcreate