Author malektronic
Recipients Phillip Middleton, bkline, cayman, chris.jerdonek, christian.heimes, fthommen, hairygristle, kscheidegger, malektronic, simon@simonfoley.net
Date 2019-10-23.15:29:43
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1571844584.09.0.779043579928.issue34028@roundup.psfhosted.org>
In-reply-to
Content
I'm having a similar problem.  I'm trying to compile on Red Hat 6.9 using a locally installed OpenSSL library.  I've tried everything here (I think) and I still get this error:

checking for openssl/ssl.h in /home/mf/dp/mpma/ghantousm/apptron/local/... yes   
checking whether compiling and linking against OpenSSL works... no               
checking for --with-ssl-default-suites... python                                 

I've ensured the libssl.* files are all present or linked to in /home/mf/dp/mpma/ghantousm/apptron/local/lib and .../lib64, the include files are present, the OpenSSL build seemed fine, and I compiled version 1.1.1d of openssl.  I've tried setting LDFLAGS and rpath and still no dice; the setup.py module doesn't seem to have any hard-coded paths so I'm really at a loss to understand what is wrong.  I've tried both versions 3.8.0 and 3.7.3 of python with the --with-openssl=/home/mf/dp/mpma/ghantousm/apptron/local option set, and version 3.6.8 (which doesn't accept any ssl related options).

This bug seems to have been preserved for a number of versions, so I'd like to help squash it if I can, but not sure where to go to from here.  I notice that some of the reports here suggest that they've had success with work-arounds, but as I stated none of them seem to work for me and I'm unable to compile with ssl support.
History
Date User Action Args
2019-10-23 15:29:44malektronicsetrecipients: + malektronic, christian.heimes, bkline, chris.jerdonek, hairygristle, simon@simonfoley.net, fthommen, kscheidegger, Phillip Middleton, cayman
2019-10-23 15:29:44malektronicsetmessageid: <1571844584.09.0.779043579928.issue34028@roundup.psfhosted.org>
2019-10-23 15:29:44malektroniclinkissue34028 messages
2019-10-23 15:29:43malektroniccreate