Author ronaldoussoren
Recipients Dmitry.Jemerov, Ilya.Kulakov, alexander.sturm, barry-scott, karolyi, larryv, lemburg, loewis, mattheww, ncoghlan, ned.deily, r.david.murray, rfrail3, ronaldoussoren, serhiy.storchaka, tsparber, wolma
Date 2019-07-13.10:55:26
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1563015327.13.0.127649081046.issue18378@roundup.psfhosted.org>
In-reply-to
Content
LC_CTYPE=UTF-8 is a valid configuration on macOS, and is in the default environment when you install a fresh system. This includes the beta's for macOS 10.15 and is therefore unlikely to change anytime soon.

Interestingly enough I get this error even when I unset the relevant environment variables. For some reason LC_CTYPE is reset when I start the interpreter, even if it is set to something else. This means the usual way of working around this problem no longer works.

I'll create a pull request with an up-to-date version of my latest patch for further discussion.

BTW. I'm testing with the current tip of the tree, but 3.7.3 fails in the same way.
History
Date User Action Args
2019-07-13 10:55:27ronaldoussorensetrecipients: + ronaldoussoren, lemburg, loewis, barry-scott, ncoghlan, mattheww, ned.deily, r.david.murray, Dmitry.Jemerov, larryv, serhiy.storchaka, wolma, Ilya.Kulakov, tsparber, karolyi, alexander.sturm, rfrail3
2019-07-13 10:55:27ronaldoussorensetmessageid: <1563015327.13.0.127649081046.issue18378@roundup.psfhosted.org>
2019-07-13 10:55:27ronaldoussorenlinkissue18378 messages
2019-07-13 10:55:26ronaldoussorencreate