Author jdemeyer
Recipients jdemeyer, methane, vstinner
Date 2019-07-03.09:46:00
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1562147161.31.0.144472808919.issue37483@roundup.psfhosted.org>
In-reply-to
Content
> PEP 7 uses C99 since Python 3.6: https://www.python.org/dev/peps/pep-0007/#c-dialect

That's not what the PEP says: "Python versions greater than or equal to 3.6 use C89 with several select C99 features"

"several select C99 features" is not the same of using C99.

Plus, I'm also worried about C++. We also support compiling C++ extensions with the same header files, so it must be C++ compatible also.
History
Date User Action Args
2019-07-03 09:46:01jdemeyersetrecipients: + jdemeyer, vstinner, methane
2019-07-03 09:46:01jdemeyersetmessageid: <1562147161.31.0.144472808919.issue37483@roundup.psfhosted.org>
2019-07-03 09:46:01jdemeyerlinkissue37483 messages
2019-07-03 09:46:00jdemeyercreate