Author steve.dower
Recipients dstufft, eric.araujo, p-ganssle, paul.moore, steve.dower, tim.golden, vstinner, zach.ware
Date 2019-07-02.20:06:22
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1562097983.47.0.889642211937.issue37481@roundup.psfhosted.org>
In-reply-to
Content
For the record, I am 100% in favor of deprecating and removing bdist_wininst and bdist_msi from distutils as soon as possible, as they are maintenance burdens and bdist_wininst in particular often attracts AV false positives.

setuptools is welcome to either do the same or restore the functionality, I don't have any preference if someone else is maintaining it (but I'd suggest removal there too until someone wants to maintain it).

Some of our distributions of Python already exclude bdist_wininst, so it can't be blindly relied on. And I don't know that it was ever upgraded for PEP 514. So far I have heard zero complaints about this, though as Paul Ganssle pointed out on the PR they're not likely to be using the "newer" packages.

So consider me +1 for deprecate in 3.8 (we can still do that, right? it's just docs and a warning on use) and remove in 3.9 or 3.10 as appropriate.
History
Date User Action Args
2019-07-02 20:06:23steve.dowersetrecipients: + steve.dower, paul.moore, vstinner, tim.golden, eric.araujo, zach.ware, dstufft, p-ganssle
2019-07-02 20:06:23steve.dowersetmessageid: <1562097983.47.0.889642211937.issue37481@roundup.psfhosted.org>
2019-07-02 20:06:23steve.dowerlinkissue37481 messages
2019-07-02 20:06:22steve.dowercreate