Author hniksic
Recipients bquinlan, hniksic, pitrou
Date 2019-05-07.14:41:40
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1557240100.35.0.0888592821305.issue36780@roundup.psfhosted.org>
In-reply-to
Content
> Are you interested in writing a patch?

Yes - I wanted to check if there is interest in the feature before I commit time to write the patch, documentation, tests, etc. (And also I wanted to check if there's a better way to do it.)

In any case, thanks for picking up on this.

> `disown` might not be the best name - maybe `allow_shutdown` or something.

Disown is an admittedly obscure reference to the shell built-in of the same name (https://tinyurl.com/qfn8ao7). The idea is to get the point across that the pool is truly abandoned, and its running futures are left to their own devices. Maybe wait_at_exit would be a clearer name:

    pool.shutdown(wait=False, wait_at_exit=True)
History
Date User Action Args
2019-05-07 14:41:40hniksicsetrecipients: + hniksic, bquinlan, pitrou
2019-05-07 14:41:40hniksicsetmessageid: <1557240100.35.0.0888592821305.issue36780@roundup.psfhosted.org>
2019-05-07 14:41:40hniksiclinkissue36780 messages
2019-05-07 14:41:40hniksiccreate