Author ncoghlan
Recipients arigo, eric.snow, ncoghlan, njs, vstinner
Date 2019-02-26.12:59:14
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1551185954.34.0.645934540587.issue35886@roundup.psfhosted.org>
In-reply-to
Content
(On closer inspection, that's actually be the same breakage as already mentioned above)

However, what I'm not clear on is how this would affect projects that had *already* generated their cffi code, and include that in their sdist. Are all those sdists going to fail to build on Python 3.8 now?

It's OK to require that extension modules be rebuilt for a new release, but breaking compatibility with a *code generator* that means a broad selection of projects are all going to fail to build is a much bigger problem.
History
Date User Action Args
2019-02-26 12:59:14ncoghlansetrecipients: + ncoghlan, arigo, vstinner, njs, eric.snow
2019-02-26 12:59:14ncoghlansetmessageid: <1551185954.34.0.645934540587.issue35886@roundup.psfhosted.org>
2019-02-26 12:59:14ncoghlanlinkissue35886 messages
2019-02-26 12:59:14ncoghlancreate