Author kellerfuchs
Recipients FR4NKESTI3N, josh.r, jwilk, kellerfuchs, mark.dickinson, rhettinger, serhiy.storchaka, steven.daprano, tim.peters
Date 2019-02-01.14:39:03
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
> > This involved a few changes, which seem to reflect the consensus here:
> > - raise ValueError if k>n ;
> > - rename the function to math.combinations.
> [...]
> > As far as I can tell from the discussions here, Steven and you stated a preference for the shortened names, and that's it.
> > There was also no reply to my comment about `comb` being confusing (due to the collision with an English word).
> >
> > Since there was, however, pretty clear agreement on calling it after combinations (shortened or not) rather than binomial(), I went with this.
> I see at least four people (myself, Raymond, Mark and Tim) giving comb 
as first choice, and I didn't see anyone give combinations as their 
first choice.
> I don't object to you taking it upon yourself to go with the longer name 
> (which is my second choice), but I do object to you claiming concensus 

I wasn't claiming consensus on the short-vs.-long name issue, but on the binomial-vs-combinations one.
I thought that would have been clear considering the context quoted above (which was missing from your reply)

Given that people clarified they prefer comb(), and that people conspicuously didn't comment on it being entirely-opaque to people who do not elready know what it is, I guess there is indeed consensus.
Date User Action Args
2019-02-01 14:39:06kellerfuchssetrecipients: + kellerfuchs, tim.peters, rhettinger, mark.dickinson, jwilk, steven.daprano, serhiy.storchaka, josh.r, FR4NKESTI3N
2019-02-01 14:39:04kellerfuchssetmessageid: <>
2019-02-01 14:39:04kellerfuchslinkissue35431 messages
2019-02-01 14:39:03kellerfuchscreate