Author martin.panter
Recipients John Jones, alex, benjamin.peterson, dhduvall, gennad, gregory.p.smith, martin.panter, miss-islington, ned.deily, neologix, pablogsal, serhiy.storchaka, vstinner
Date 2018-05-14.08:15:45
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1526285745.67.0.682650639539.issue20104@psf.upfronthosting.co.za>
In-reply-to
Content
I suggested the “scheduler” tuple to bring the two related parameters (scheduling policy and sched_param) together, similar to how they are paired as the second and third parameters to “os.sched_setscheduler”, and because I thought it would imply that a scheduling policy without sched_param is not valid.

But separate keyword parameters would also work if you prefer. I might call them “schedpolicy” and “schedparam”, but if you prefer the naming scheme in the current proposal, you could call them “setscheduler” and “setschedparam”. Although in that case, setting the “setscheduler” parameter on its own would not be sufficient to correctly set the POSIX_SPAWN_SETSCHEDULER flag.
History
Date User Action Args
2018-05-14 08:15:45martin.pantersetrecipients: + martin.panter, gregory.p.smith, vstinner, benjamin.peterson, ned.deily, alex, dhduvall, neologix, gennad, serhiy.storchaka, John Jones, pablogsal, miss-islington
2018-05-14 08:15:45martin.pantersetmessageid: <1526285745.67.0.682650639539.issue20104@psf.upfronthosting.co.za>
2018-05-14 08:15:45martin.panterlinkissue20104 messages
2018-05-14 08:15:45martin.pantercreate