Author OO O
Recipients OO O, paul.moore, steve.dower, tim.golden, zach.ware
Date 2018-02-03.21:14:21
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1517692462.01.0.467229070634.issue32759@psf.upfronthosting.co.za>
In-reply-to
Content
OS: Win10 / 8.1
Python: 3.5 / 3.6

My program use mp.Array to share huge data.
But suffer from out of memory after running for a while. 

But Windows task manager didn't show which process use that huge memory. And I use pympler to check my python memory usage. Still shows noting. So, I use RamMap to check, it shows a huge shared memory is used.

I can reproduce the case by the simple test code:
   #-------------------------------------------------------
   import numpy as np
   import multiprocessing as mp
   import gc

   def F ():
       a = mp.Array ( 'I', 1800000000, lock = False )

   #
   F ()
   gc.collect ()
   #-------------------------------------------------------

No matter how hard I tried. the memory is not released.
I put what I tried in the attachment picture.
History
Date User Action Args
2018-02-03 21:14:22OO Osetrecipients: + OO O, paul.moore, tim.golden, zach.ware, steve.dower
2018-02-03 21:14:22OO Osetmessageid: <1517692462.01.0.467229070634.issue32759@psf.upfronthosting.co.za>
2018-02-03 21:14:21OO Olinkissue32759 messages
2018-02-03 21:14:21OO Ocreate