Author Steve Barnes
Recipients Steve Barnes
Date 2017-05-06.09:57:32
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1494064652.52.0.930357680293.issue30291@psf.upfronthosting.co.za>
In-reply-to
Content
Currently you can use, assuming all are installed:

py -2 # gets the latest python 2 with 64 bit as the default
py -2.7 # gets python 2.7 with 64 bit as the default
py -2.7-32 # gets -32 bit python 2.7
py -3 # gets the latest python 3 with 64 bit as the default
py -3.5 # gets python 3.5 with 64 bit as the default
py -3.5-32 # gets -32 bit python 3.5

But you cannot use:

py -2-32 # Usage Error but would be handy for the latest 32 bit python 2
py -3-32 # Usage Error but would be handy for the latest 32 bit python 3

Note that you also cannot use:
py -3.5-64  # Unknown option: -3 would be handy for testing with I need 64 bit python 3.5 with an error if it doesn't exist currently -3.5 defaults to 3.5 64 bit if available 32 bit otherwise.

For testing packages and programs it would be very useful to be able to specify any of:

 - Latest available 32 bit python 2 or 3
 - 64 bit python 3 fail if unavailable.
History
Date User Action Args
2017-05-06 09:57:32Steve Barnessetrecipients: + Steve Barnes
2017-05-06 09:57:32Steve Barnessetmessageid: <1494064652.52.0.930357680293.issue30291@psf.upfronthosting.co.za>
2017-05-06 09:57:32Steve Barneslinkissue30291 messages
2017-05-06 09:57:32Steve Barnescreate