Author inada.naoki
Recipients bquinlan, desbma, inada.naoki
Date 2017-01-23.01:27:03
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
I don't think this is a regression, bug, bogos naming.

I agree that "<concurrent.futures.thread.ThreadPoolExecutor object at 0x7f96711ac278>_0" is ugly.
But the name describes what is the thread, than "Thread-1".

How about giving default thread_name_prefix less ugly?
e.g. "ThreadPoolExecutor-worker".
Date User Action Args
2017-01-23 01:27:04inada.naokisetrecipients: + inada.naoki, bquinlan, desbma
2017-01-23 01:27:04inada.naokisetmessageid: <>
2017-01-23 01:27:04inada.naokilinkissue29212 messages
2017-01-23 01:27:03inada.naokicreate