Author ncoghlan
Recipients ncoghlan, njs
Date 2017-01-03.01:47:57
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1483408078.24.0.445340769668.issue29137@psf.upfronthosting.co.za>
In-reply-to
Content
- 3.4 is already in security-fix only mode so we can safely ignore it for this purpose

- 3.5.3 is likely to be the last general bugfix release of 3.5, so we can probably skip that as well

- that would mean the ABI compability shims would only go in 3.6.1 and the next 2.7 release

At that point, does it actually make sense to provide the shims? Or should we instead just add the deprecation warnings and say "Don't use the --with-fpectl option, as it doesn't work properly, and breaks ABI compatibility for extension modules built with that Python"?

And then add a build time "#pragma message '--with-fpectl' is deprecated as it breaks extension module ABI compatibility" to the WANT_SIGFPE_HANDLER branch in Include/fpectl.h
History
Date User Action Args
2017-01-03 01:47:58ncoghlansetrecipients: + ncoghlan, njs
2017-01-03 01:47:58ncoghlansetmessageid: <1483408078.24.0.445340769668.issue29137@psf.upfronthosting.co.za>
2017-01-03 01:47:58ncoghlanlinkissue29137 messages
2017-01-03 01:47:57ncoghlancreate