Author bar.harel
Recipients NeilGirdhar, bar.harel, brett.cannon, gvanrossum, levkivskyi, rhettinger, srkunze
Date 2016-08-23.15:45:58
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
I still believe "Reiterable" better demonstrates the concept.

When you request a Reiterable as a function parameter or assert if something is a Reiterable the other side knows exactly what you mean.

A "Collection" is way more ambiguous - if you create an object that acts like range() but you can cycle over it more than once I wouldn't exactly call it a collection. I would though call it a Reiterable and it would be clear for any Python programmer familiar with the concept of iterators.

I believe this is a funny case in which the naming is more important than the implementation as it will turn into a term or concept that will be further used in many places to come.
Date User Action Args
2016-08-23 15:45:58bar.harelsetrecipients: + bar.harel, gvanrossum, brett.cannon, rhettinger, NeilGirdhar, levkivskyi, srkunze
2016-08-23 15:45:58bar.harelsetmessageid: <>
2016-08-23 15:45:58bar.harellinkissue27598 messages
2016-08-23 15:45:58bar.harelcreate