Author zach.ware
Recipients ned.deily, paul.moore, steve.dower, tim.golden, zach.ware
Date 2016-05-20.21:27:25
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
I'm very much +1 on the patch.

A couple thoughts:
- Note that 2.7 doesn't come with a launcher.

- As I understand it, the 3.5+ installer won't overwrite a newer launcher than what it would install, but the 3.4- installer will.  So the only really confusing (to my mind) thing that could happen would be someone installing 3.4 after 2.7 and 3.6, and the newly installed old 3.4 launcher reverts to defaulting to 2.x.  There's not much we can do about that, though: there will be no more 3.3 or 3.4 installers, so an update to the launcher in those branches would never see the light of day anyway.  I think this is an uncommon-enough situation that it can be ignored, but one possible way to work around it would be to install a pro-3 py.ini along with the launcher in 3.6+ (if it wouldn't be overwriting an existing py.ini).  Probably more effort than it's worth, though.
Date User Action Args
2016-05-20 21:27:25zach.waresetrecipients: + zach.ware, paul.moore, tim.golden, ned.deily, steve.dower
2016-05-20 21:27:25zach.waresetmessageid: <>
2016-05-20 21:27:25zach.warelinkissue27064 messages
2016-05-20 21:27:25zach.warecreate