This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author serhiy.storchaka
Recipients serhiy.storchaka, terry.reedy
Date 2016-05-15.08:04:05
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1463299445.94.0.887025569149.issue27025@psf.upfronthosting.co.za>
In-reply-to
Content
For now Tkinter generates Tk widget names just from Widget instance id.

>>> import tkinter
>>> root = tkinter.Tk()
>>> frame = tkinter.Frame(root)
>>> button = tkinter.Button(frame)
>>> str(button)
'.3070531884.3055478668'

These names are not very readable and distinguishable. I think it would be better to generate names from widget type and short sequential number. For example '.frame#1.button#2' or '.1frame.2button'.

There are some questions:

1. Should numbering be continuous or separate for different types of widgets?

2. Should a number precede or follow a widget type?

3. What separator, prefix or suffix be used? "#" looks too common and can lead to conflicts with user defined names or names generated by Tk or special Tk syntax.
History
Date User Action Args
2016-05-15 08:04:06serhiy.storchakasetrecipients: + serhiy.storchaka, terry.reedy
2016-05-15 08:04:05serhiy.storchakasetmessageid: <1463299445.94.0.887025569149.issue27025@psf.upfronthosting.co.za>
2016-05-15 08:04:05serhiy.storchakalinkissue27025 messages
2016-05-15 08:04:05serhiy.storchakacreate