This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author jhamrick
Recipients jhamrick
Date 2015-07-04.20:26:59
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
Some further information: if I run copystat directly on 3.4.3, I get essentially the same error as on 3.4.0. So really it only looks like the difference is just in how the error is reported:

Traceback (most recent call last):
  File "", line 31, in <module>
    shutil.copystat('demo_files', 'demo_files3')
  File "/usr/lib/python3.4/", line 213, in copystat
    _copyxattr(src, dst, follow_symlinks=follow)
  File "/usr/lib/python3.4/", line 153, in _copyxattr
    os.setxattr(dst, name, value, follow_symlinks=follow_symlinks)
OSError: [Errno 22] Invalid argument: 'demo_files3'

Also, I should mention that I did test this on 2.7 as well, and it is not an issue there.
Date User Action Args
2015-07-04 20:26:59jhamricksetrecipients: + jhamrick
2015-07-04 20:26:59jhamricksetmessageid: <>
2015-07-04 20:26:59jhamricklinkissue24564 messages
2015-07-04 20:26:59jhamrickcreate