Author serhiy.storchaka
Recipients Arfrever, berker.peksag, ethan.furman, mark.dickinson, ncoghlan, petr.viktorin, r.david.murray, serhiy.storchaka, terry.reedy, yselivanov
Date 2015-05-22.18:39:12
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1432319952.32.0.94590958647.issue24056@psf.upfronthosting.co.za>
In-reply-to
Content
I like the look of the repr Terry proposes better. For generator objects the repr is either "<coroutine object %S at %p>" or "<generator object %S at %p>". "<coroutine function %S at %p>" and "<generator function %S at %p>" would be consistent with this. It also shows the relation and the difference between the generator function and the generator object.

Yet one argument is that both terms "generator object" and "generator function" are searchable in the documentation.

There are other precedences with exposing flags at the start of the repr. "<built-in function %s>" and "<built-in method %s of %s object at %p>", "<unlocked %s object at %p>" and "<locked %s object at %p>".
History
Date User Action Args
2015-05-22 18:39:12serhiy.storchakasetrecipients: + serhiy.storchaka, terry.reedy, mark.dickinson, ncoghlan, Arfrever, r.david.murray, petr.viktorin, ethan.furman, berker.peksag, yselivanov
2015-05-22 18:39:12serhiy.storchakasetmessageid: <1432319952.32.0.94590958647.issue24056@psf.upfronthosting.co.za>
2015-05-22 18:39:12serhiy.storchakalinkissue24056 messages
2015-05-22 18:39:12serhiy.storchakacreate