Author Al.Sweigart
Recipients Al.Sweigart
Date 2015-05-18.07:36:26
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
From the idlelib/idle_test/README.txt file:

"The idle_test subdirectory should contain a for each, where 'xyz' is lowercased even if is not."

However, this means the test file names are inconsistent with the scripts they test. Of the 20 test_*.py files, all 20 are inconsistent. Some of the test filenames don't even match the file, such as which tests

Since the original filenames aren't lowercase like the rest of the standard library, it would be better to rename them rather than renaming the test files: to, to, etc. This is a find-and-replace change. Any shorter, better names for modules can also be made at this time.
Date User Action Args
2015-05-18 07:36:27Al.Sweigartsetrecipients: + Al.Sweigart
2015-05-18 07:36:27Al.Sweigartsetmessageid: <>
2015-05-18 07:36:27Al.Sweigartlinkissue24225 messages
2015-05-18 07:36:26Al.Sweigartcreate