This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author berker.peksag
Recipients berker.peksag, eric.smith, lars.gustaebel, mvo, r.david.murray, serhiy.storchaka, vstinner
Date 2015-04-14.04:33:22
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
* +.. method:: TarFile.extractall(path=".", members=None, numeric_owner=False)

  numeric_owner can be a keyword-only argument.

* TarFile.extract and TarFile.extractall docs need a versionchanged directive.

* It would be nice to add an entry to Doc/whatsnew/3.5.rst

* +        filename_1 = fname
  +        dirname_1 = dirname
  +        filename_2 = os.path.join(dirname, fname)

  I'd just yield fname, dirname, os.path.join(dirname, fname) here.

* +            for name, uid, gid, typ, contents in [(fname, 99, 98, tarfile.REGTYPE, fobj),
  +                                                  (dirname, 77, 76, tarfile.DIRTYPE, None),
  +                                                  (os.path.join(dirname, fname), 88, 87, tarfile.REGTYPE, fobj),
  +                                                  ]:

  Moving the list to a new variable would be more readable.

* Typo: # ceate -> # create

* +def root_is_uid_gid_0():

  Question: Can't we use something like root_in_posix in test_os here?

* +        with as r:

  Nitpick: What does "r" mean here? "tar" or "tarobj" looks more readable to me.

* Nitpick: I'd prefer ``None`` over :const:`True`. However, the current style is just "true" in the tarfile documentation.
Date User Action Args
2015-04-14 04:33:22berker.peksagsetrecipients: + berker.peksag, lars.gustaebel, vstinner, eric.smith, mvo, r.david.murray, serhiy.storchaka
2015-04-14 04:33:22berker.peksagsetmessageid: <>
2015-04-14 04:33:22berker.peksaglinkissue23193 messages
2015-04-14 04:33:22berker.peksagcreate