This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author martin.panter
Recipients berker.peksag, docs@python, martin.panter, r.david.murray, zbysz
Date 2015-03-23.02:52:45
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1427079165.52.0.141060671086.issue23725@psf.upfronthosting.co.za>
In-reply-to
Content
The current proposed text would be rendered something like this:

'''
TemporaryFile, NamedTemporaryFile, TemporaryDirectory, SpooledTemporaryFile are high-level interfaces which provide automatic cleanup and can be used as context managers. mkstemp() and mkdtemp() are lower-level functions which require manual cleanup.
'''

My opinion is it is very often worthwhile rewording the sentence. It is awkward to read at the moment, especially if you are trying to skim over it without reading the whole paragraph. Unlike in Python, in English there’s always more than one way to do it. Perhaps you could consider this version instead:

'''
The TemporaryFile, NamedTemporaryFile, TemporaryDirectory, [and] SpooledTemporaryFile classes are high-level interfaces which provide automatic cleanup and can be used as context managers. The mkstemp() and mkdtemp() functions are lower-level, and require manual cleanup.
'''

Only about three more words, and not particularly convoluted. But if you disagree, I can live with it, since there are plenty more examples of this in the Python documentation and elsewhere :)

Other than that, I think the patch is good.
History
Date User Action Args
2015-03-23 02:52:45martin.pantersetrecipients: + martin.panter, r.david.murray, zbysz, docs@python, berker.peksag
2015-03-23 02:52:45martin.pantersetmessageid: <1427079165.52.0.141060671086.issue23725@psf.upfronthosting.co.za>
2015-03-23 02:52:45martin.panterlinkissue23725 messages
2015-03-23 02:52:45martin.pantercreate