This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author terry.reedy
Recipients niacdoial, steve.dower, terry.reedy, tim.golden, zach.ware
Date 2015-03-09.21:19:05
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
At one time, there would not have been any point. contains this sentence "For a package, the same effect can be achieved by including a module, the contents of which will be executed when the module is run with -m.", which was new for 3.0.  The .../2/... doc does not as this is a new-in-3.0 feature.  Thus, I am surprised by
C:\Users\Terry>py -m idlelib
C:\Programs\Python27\python.exe: No module named idlelib.__main__; 'idlelib' is a package and cannot be directly executed
AFAIK, 2.7 should not even be looking for .__main__.

After I copied idlelib/ to my 2.7 install and repeated the command line, Idle tried to start, but imports of submodules failed, subprocess connection failed, and the editor was opened for blank numbered files like 'C:/programs/python27/50343'.  After that, normal ways of starting Idle also failed similarly.  Reinstalling 2.7 (with remnamts of the old idlelib left) did not fix things.  The only way I found to restore Idle was to delete 2.7 idlelib/ completely and run Programs and Features (win 7) repair, which restores a fresh copy that works again.  I tried again with same results, so I am done experimenting.
Date User Action Args
2015-03-09 21:19:05terry.reedysetrecipients: + terry.reedy, tim.golden, zach.ware, steve.dower, niacdoial
2015-03-09 21:19:05terry.reedysetmessageid: <>
2015-03-09 21:19:05terry.reedylinkissue23546 messages
2015-03-09 21:19:05terry.reedycreate