Author rhettinger
Recipients Arfrever, docs@python, ethan.furman, ezio.melotti, georg.brandl, r.david.murray, rhettinger, terry.reedy, tshepang, vy0123
Date 2014-11-05.08:29:23
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
I'm sorry but I do not like the proposed patch at all.  The wording is awkward "which when iterated" and has weird terminology "the sequence number".

The OP's concern about the *sequence* versus *iterable* parameter name has been addressed (it is part of the 2.7 API and is unchangeable).

I see no need for revising the text which already discusses "sequence or some other object that supports iterable", that has clear examples, and that has pure python equivalent code.   The existing wording has worked well for most people for the better part of a decade.
Date User Action Args
2014-11-05 08:29:23rhettingersetrecipients: + rhettinger, georg.brandl, terry.reedy, ezio.melotti, Arfrever, r.david.murray, docs@python, ethan.furman, tshepang, vy0123
2014-11-05 08:29:23rhettingersetmessageid: <>
2014-11-05 08:29:23rhettingerlinkissue22725 messages
2014-11-05 08:29:23rhettingercreate