Message224170
> os and socket modules already use getxxx() / setxxx() names:
>
> - os.get_inheritable() / os.set_inheritable()
> - os.getuid() / os.setuid()
> - os.getgroups() / os.setgroups()
> - os.getxattr() os.setxattr()
> - socket.gettimeout() / socket.settimeout()
> - socket.get_inheritable() / socket.set_inheritable()
> - etc.
egid, euid, gid, groups, pgid, pgrp, priority, resgid, sid, uid, xatrr,
hostname, timeout, sockopt are not boolean. Though
get_inheritable() spoils the pot.
Compare:
if os.get_blocking(fd): # is it a bug? Does it return some mode bits?
# Do I need stat.IS_BLK(os.get_blocking(fd)) here instead?
And:
if os.is_blocking(fd):
# it is clear that fd is blocking
There could be an argument that get_inheritable should be renamed to
is_inheritable instead. |
|
Date |
User |
Action |
Args |
2014-07-28 14:52:46 | akira | set | recipients:
+ akira, pitrou, vstinner, neologix |
2014-07-28 14:52:46 | akira | link | issue22054 messages |
2014-07-28 14:52:45 | akira | create | |
|