Author Lukas.Vacek
Recipients Lukas.Vacek, Peter.Kruse, athompson, christian.heimes, fdrake, gregory.p.smith, python-dev
Date 2014-05-09.15:02:30
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1399647751.85.0.65628687649.issue19186@psf.upfronthosting.co.za>
In-reply-to
Content
Hi Peter,

Thanks for taking the time to report your issue. I just tried on fresh up-to-date CentOS 6 and I could not reproduce the issue.

However, I think I figured out what went wrong. I can see you are supplying custom -I and -L paths (-I/apps/prod/releases/3.0/include ...) I suspect that when compiling pyexpat.c (in Modules/) the header file expat.h is picked up from this location before the bundled expat.h (in Modules/expat/) is found. But when compiling xmlparse.c (in Modules/expat/) the bundled header file expat.h *is* used this time. So we end up with our bundled expat compiled using namespacing and so defining symbols like PyExpat_XML_SetCommentHandler while pyexpat.c is looking for XML_SetCommentHandler because it is compiled *not* using our bundled expat.h.

I am not sure yet why your custom "-I" comes before "-I/ae/data/soft/opensource/build/python3/master/Python-3.4.0/Modules/expat" as it certainly should not. 

So far I tried building with CPPFLAGS and CFLAGS and in both cases my custom paths come after "-I.../Modules/expat" as it should.

Can you please provide your ./configure and make command lines and relevant environment variables?

Thanks,
Lucas
History
Date User Action Args
2014-05-09 15:02:31Lukas.Vaceksetrecipients: + Lukas.Vacek, fdrake, gregory.p.smith, christian.heimes, python-dev, athompson, Peter.Kruse
2014-05-09 15:02:31Lukas.Vaceksetmessageid: <1399647751.85.0.65628687649.issue19186@psf.upfronthosting.co.za>
2014-05-09 15:02:31Lukas.Vaceklinkissue19186 messages
2014-05-09 15:02:30Lukas.Vacekcreate