Author neologix
Recipients neologix
Date 2014-03-25.08:12:53
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1395735174.52.0.231038807129.issue21059@psf.upfronthosting.co.za>
In-reply-to
Content
Many buildbots are failing with this error:
"""
======================================================================
ERROR: idlelib.idle_test.test_warning (unittest.loader.ModuleImportFailure)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "E:\Data\buildslave\cpython\3.x.snakebite-win2k3r2sp2-x86\build\lib\unittest\case.py", line 57, in testPartExecutor
    yield
  File "E:\Data\buildslave\cpython\3.x.snakebite-win2k3r2sp2-x86\build\lib\unittest\case.py", line 574, in run
    testMethod()
  File "E:\Data\buildslave\cpython\3.x.snakebite-win2k3r2sp2-x86\build\lib\unittest\loader.py", line 32, in testFailure
    raise exception
ImportError: Failed to import test module: idlelib.idle_test.test_warning
Traceback (most recent call last):
  File "E:\Data\buildslave\cpython\3.x.snakebite-win2k3r2sp2-x86\build\lib\unittest\loader.py", line 312, in _find_tests
    module = self._get_module_from_name(name)
  File "E:\Data\buildslave\cpython\3.x.snakebite-win2k3r2sp2-x86\build\lib\unittest\loader.py", line 290, in _get_module_from_name
    __import__(name)
  File "E:\Data\buildslave\cpython\3.x.snakebite-win2k3r2sp2-x86\build\lib\idlelib\idle_test\test_warning.py", line 19, in <module>
    from idlelib import run
  File "E:\Data\buildslave\cpython\3.x.snakebite-win2k3r2sp2-x86\build\lib\idlelib\run.py", line 58, in <module>
    tcl = tkinter.Tcl()
  File "E:\Data\buildslave\cpython\3.x.snakebite-win2k3r2sp2-x86\build\lib\tkinter\__init__.py", line 1901, in Tcl
    return Tk(screenName, baseName, className, useTk)
  File "E:\Data\buildslave\cpython\3.x.snakebite-win2k3r2sp2-x86\build\lib\tkinter\__init__.py", line 1805, in __init__
    self.tk = _tkinter.create(screenName, baseName, className, interactive, wantobjects, useTk, sync, use)
_tkinter.TclError: Can't find a usable init.tcl in the following directories: 
    E:/Data/buildslave/cpython/3.x.snakebite-win2k3r2sp2-x86/build/lib/tcl8.6 E:/Data/buildslave/cpython/3.x.snakebite-win2k3r2sp2-x86/build/lib/tcl8.6 E:/Data/buildslave/cpython/3.x.snakebite-win2k3r2sp2-x86/lib/tcl8.6 E:/Data/buildslave/cpython/3.x.snakebite-win2k3r2sp2-x86/build/library E:/Data/buildslave/cpython/3.x.snakebite-win2k3r2sp2-x86/library E:/Data/buildslave/cpython/3.x.snakebite-win2k3r2sp2-x86/tcl8.6.1/library E:/Data/buildslave/cpython/tcl8.6.1/library



This probably means that Tcl wasn't installed properly.
"""

See e.g. http://buildbot.python.org/all/builders/x86%20Windows%20Server%202003%20%5BSB%5D%203.x/builds/2274/steps/test/logs/stdio
History
Date User Action Args
2014-03-25 08:12:54neologixsetrecipients: + neologix
2014-03-25 08:12:54neologixsetmessageid: <1395735174.52.0.231038807129.issue21059@psf.upfronthosting.co.za>
2014-03-25 08:12:54neologixlinkissue21059 messages
2014-03-25 08:12:53neologixcreate