Author r.david.murray
Recipients python-dev, r.david.murray, vajrasky
Date 2014-03-08.01:23:37
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
Revisiting this with fresh eyes, I no longer think this was a typo, and I think we shouldn't have changed it and should change it back (but keep the 'p' names as aliases for those who expect the man page names to be valid).

My logic is: 'sp_namp' is so named because it is a C char *pointer* to the password.  But Python doesn't have pointers in the C sense, so in the python object there is no pointer/non-pointer distinction between sp_namp, sp_pwdp, and all of the rest of the fields.  Thus the original decision to drop the 'p', which makes the names easier to type and more consistent with the other field names, there being no pointer distinction in python.

But I do like having the 'p' aliases, as I said above, because someone familiar with the C struct might use them automatically, and since this is a thin wrapper around the C API, we ought to support the C names, I think.  And besides, its too late now to remove them ;)

So, I'm reopening this because I'd like to revert the docs, remove the deprecation, and document the 'p' versions as aliases.
Date User Action Args
2014-03-08 01:23:41r.david.murraysetrecipients: + r.david.murray, python-dev, vajrasky
2014-03-08 01:23:40r.david.murraysetmessageid: <>
2014-03-08 01:23:40r.david.murraylinkissue18678 messages
2014-03-08 01:23:37r.david.murraycreate