Author exhuma
Recipients exhuma, ncoghlan, pitrou, pmoody, r.david.murray
Date 2014-03-04.08:19:01
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
I second "supernet_of" and "subnet_of". I'll implement it as soon as I get around it.

I have been thinking about using ``in`` and ``<=`` and, while I initially liked the idea for tests, I find both operators too ambiguous.

With ``in`` there's the already mentioned ambiguity of containment/inclusion. And ``<=`` could mean is a smaller size (has less individual hosts), but could also mean that it is a subnet, or even that it is "located to the left".

Naming it ``subnet_of`` makes it 100% clear what it does.

Currently, ``a <= b`` returns ``True`` if a comes before/lies on the left of b.
Date User Action Args
2014-03-04 08:19:01exhumasetrecipients: + exhuma, ncoghlan, pitrou, pmoody, r.david.murray
2014-03-04 08:19:01exhumasetmessageid: <>
2014-03-04 08:19:01exhumalinkissue20825 messages
2014-03-04 08:19:01exhumacreate