This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author taleinat
Recipients benjamin.peterson, brett.cannon, georg.brandl, kristjan.jonsson, larry, loewis, pitrou, rhettinger, serhiy.storchaka, skrah, taleinat, vstinner
Date 2014-02-25.21:44:05
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
While we're bikeshedding, how about the more verbose PY_DECREF_AND_ASSIGN? That makes it clearer that an INCREF is not done.

Regarding Kristján's suggestion of PY_ASSIGN and a complementary PY_STORE, IMO these names are too similar and the difference between them is not clear.
Date User Action Args
2014-02-25 21:44:05taleinatsetrecipients: + taleinat, loewis, brett.cannon, georg.brandl, rhettinger, pitrou, kristjan.jonsson, vstinner, larry, benjamin.peterson, skrah, serhiy.storchaka
2014-02-25 21:44:05taleinatsetmessageid: <>
2014-02-25 21:44:05taleinatlinkissue20440 messages
2014-02-25 21:44:05taleinatcreate