Author leonn
Recipients eric.smith, leonn, ncoghlan, pitrou, pmoody
Date 2014-02-02.02:13:19
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
Thanks for the feedback, I agree "reverse_pointer" is a better, less ambiguous name for the property. I’ve amended the patch to reflect this suggestion.

Regarding the trailing dot, I felt it more appropriate to have it that to leave it out, but I don’t have a strong opinion on this. It has to be there in the DNS query, but most tools will automatically add it to the query if it’s not specified. The "host" tool from bind-utils is undecided as well when printing the output, it includes the trailing dot when querying IPv4 addresses, but not for IPv6 addresses.

Including the trailing dot has the advantage that the output could be directly fed into other code that strictly requires it, like the dnspython module.

I’ll sign and submit the contributor’s agreement as soon as I’m within reach of a printer (likely within the next 24 hours).
Date User Action Args
2014-02-02 02:13:20leonnsetrecipients: + leonn, ncoghlan, pitrou, eric.smith, pmoody
2014-02-02 02:13:20leonnsetmessageid: <>
2014-02-02 02:13:20leonnlinkissue20480 messages
2014-02-02 02:13:19leonncreate