This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author serhiy.storchaka
Recipients georg.brandl, larry, pitrou, serhiy.storchaka, zach.ware
Date 2014-01-17.11:53:48
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
Can Argument Clinic be simplified when drop support for all alternative outputs besides a side file?

> * "args" and "kwargs" variables in C renamed to "_args" and "_kwargs"

Why this is needed? If buildin function has "args" or "kwargs" keyword arguments, C variables can be renamed to args_value and kwargs_value, as for any reserved keywords (e.g. "default", "int"). Other changes look very good, but these are just add code churn.
Date User Action Args
2014-01-17 11:53:48serhiy.storchakasetrecipients: + serhiy.storchaka, georg.brandl, pitrou, larry, zach.ware
2014-01-17 11:53:48serhiy.storchakasetmessageid: <>
2014-01-17 11:53:48serhiy.storchakalinkissue20287 messages
2014-01-17 11:53:48serhiy.storchakacreate