Author ncoghlan
Recipients Arfrever, brett.cannon, eric.snow, ncoghlan
Date 2013-12-11.12:27:37
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <CADiSq7eG+0E8p6DPxo1e_KbLm6=ckfuUUVg1W=VG+=Jzauyn1w@mail.gmail.com>
In-reply-to <1386741564.68.0.728669153183.issue19944@psf.upfronthosting.co.za>
Content
One function (the current one) promises not to import anything. The other
(the new one) may have side effects, even if it fails to find the module
(any successfully imported parent modules will remain imported).

IIRC, that "no side effects" guarantee was the original reason for the
find_loader/get_loader split and it's a distinction I think is worth
preserving. I just think the obvious name should be closer to
importlib.import_module in semantics, with the "no side effects" version
being the more obscure one.
History
Date User Action Args
2013-12-11 12:27:37ncoghlansetrecipients: + ncoghlan, brett.cannon, Arfrever, eric.snow
2013-12-11 12:27:37ncoghlanlinkissue19944 messages
2013-12-11 12:27:37ncoghlancreate