This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author vstinner
Recipients rstarostecki, skrah, vstinner
Date 2013-12-09.00:30:50
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
Sorry, but I still don't understand this issue.

"Invalid read of size 4" is a known false positive. It can be worked around using ./configure --with-valgrind and the suppression list, or using ./configure --without-pymalloc. If you still get the warning, you used the wrong options or you are still using another Python binary (or shared library). Make sure that you are linked to your newly compiled shared library.

"valgrind --leak-check=full --log-file=valgrind.log ./python -c pass" shows me "possibly lost: 286,779 bytes in 654 blocks". This is also another known issue: Python doesn't release all the memory at exit, they are many "singletons" and variables initialized once but never released.

The PEP 3121 helps this issue but the PEP is not fully implemented yet, many modules should still be modified.

So what is your question? Do you think that Python leaks memory? Why do you think so?
Date User Action Args
2013-12-09 00:30:50vstinnersetrecipients: + vstinner, skrah, rstarostecki
2013-12-09 00:30:50vstinnersetmessageid: <>
2013-12-09 00:30:50vstinnerlinkissue19893 messages
2013-12-09 00:30:50vstinnercreate