Author Dubslow
Recipients Dubslow, christian.heimes, dstufft, ncoghlan, python-dev, tim.peters
Date 2013-11-25.11:50:36
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1385380237.28.0.0721902602789.issue19744@psf.upfronthosting.co.za>
In-reply-to
Content
I've stumbled upon what appears to be a related issue, but I'm not sure it deserves its own bug report.

I compiled 3.4 on my LMDE (so essentially Debian testing) system, and aside from not building tkinter, various compression modules, etc., all went well. I ran `make test` with no errors, including the success of test_venv. (There were many and various warnings about deprecated code and calling str() on bytes instances, but I'm pretty sure none of it is related).

I ran `sudo make altinstall` (to not nuke my current 3.3 from the repos), and to my surprise, it failed with the following error:




running install_scripts
copying build/scripts-3.4/pydoc3.4 -> /usr/local/bin
copying build/scripts-3.4/2to3-3.4 -> /usr/local/bin
copying build/scripts-3.4/idle3.4 -> /usr/local/bin
copying build/scripts-3.4/pyvenv-3.4 -> /usr/local/bin
changing mode of /usr/local/bin/pydoc3.4 to 755
changing mode of /usr/local/bin/2to3-3.4 to 755
changing mode of /usr/local/bin/idle3.4 to 755
changing mode of /usr/local/bin/pyvenv-3.4 to 755
rm /usr/local/lib/python3.4/lib-dynload/_sysconfigdata.py
rm -r /usr/local/lib/python3.4/lib-dynload/__pycache__
/usr/bin/install -c -m 644 ./Misc/python.man \
                /usr/local/share/man/man1/python3.4.1
if test "xupgrade" != "xno"  ; then \
                case upgrade in \
                  upgrade) ensurepip="--altinstall --upgrade" ;; \
                  install|*) ensurepip="--altinstall" ;; \
                esac; \
                 ./python -E -m ensurepip \
                  $ensurepip --root=/ ; \
        fi
Traceback (most recent call last):
  File "/home/bill/py3.4/Python-3.4.0b1/Lib/runpy.py", line 160, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/home/bill/py3.4/Python-3.4.0b1/Lib/runpy.py", line 73, in _run_code
    exec(code, run_globals)
  File "/home/bill/py3.4/Python-3.4.0b1/Lib/ensurepip/__main__.py", line 66, in <module>
    main()
  File "/home/bill/py3.4/Python-3.4.0b1/Lib/ensurepip/__main__.py", line 61, in main
    default_pip=args.default_pip,
  File "/home/bill/py3.4/Python-3.4.0b1/Lib/ensurepip/__init__.py", line 92, in bootstrap
    _run_pip(args + [p[0] for p in _PROJECTS], additional_paths)
  File "/home/bill/py3.4/Python-3.4.0b1/Lib/ensurepip/__init__.py", line 28, in _run_pip
    import pip
  File "/tmp/tmprwpsemxj/pip-1.5.rc1-py2.py3-none-any.whl/pip/__init__.py", line 10, in <module>
  File "/tmp/tmprwpsemxj/pip-1.5.rc1-py2.py3-none-any.whl/pip/util.py", line 17, in <module>
  File "/tmp/tmprwpsemxj/pip-1.5.rc1-py2.py3-none-any.whl/pip/_vendor/distlib/version.py", line 14, in <module>
  File "/tmp/tmprwpsemxj/pip-1.5.rc1-py2.py3-none-any.whl/pip/_vendor/distlib/compat.py", line 66, in <module>
ImportError: cannot import name 'HTTPSHandler'
make: *** [altinstall] Error 1




Note: I will certainly *not* be trying to `sudo make install`.

In any case, the executable and modules were installed fine, so other than reporting it here, it's not causing me problems (so far).
History
Date User Action Args
2013-11-25 11:50:37Dubslowsetrecipients: + Dubslow, tim.peters, ncoghlan, christian.heimes, python-dev, dstufft
2013-11-25 11:50:37Dubslowsetmessageid: <1385380237.28.0.0721902602789.issue19744@psf.upfronthosting.co.za>
2013-11-25 11:50:37Dubslowlinkissue19744 messages
2013-11-25 11:50:36Dubslowcreate