Author ronaldoussoren
Recipients d9pouces, eric.araujo, jrjsmrtn, markgrandi, ned.deily, r.david.murray, ronaldoussoren, serhiy.storchaka
Date 2013-11-19.19:59:06
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1384891146.59.0.930937881752.issue14455@psf.upfronthosting.co.za>
In-reply-to
Content
I for the most part agree with the comments and will provide an updated patch on thursday. Would you mind if I committed that without further review (due to cutting it awfully close to the deadline for beta 1)?

Some comments I want to reply to specifically:

* "Can the code be simpler, with only one pass?"

   Maybe, but not right now. 

* "This is inconsistent with _flatten()."

  I'll add a comment that explains why this is: _flatten (and this code) 
  can deal with arbitrary keys, but that is not supported by Apple's code.

  The type check in _write_object ensures that it is not possible to write
  archives that cannot be read back by Apple's Cocoa frameworks.

* "unusual indentation" (several times)

  I'll have to look at other stdlib code to find suitable indentation, this
  is indentation I've used in my code for a long time (I've also used 
  camelCase instead of pep8_style names for methods for a long time, which 
  is probably why I never noticed that I forgot to convert some method 
  name when cleaning up the naming conventions used in this module).
History
Date User Action Args
2013-11-19 19:59:06ronaldoussorensetrecipients: + ronaldoussoren, ned.deily, eric.araujo, r.david.murray, jrjsmrtn, serhiy.storchaka, d9pouces, markgrandi
2013-11-19 19:59:06ronaldoussorensetmessageid: <1384891146.59.0.930937881752.issue14455@psf.upfronthosting.co.za>
2013-11-19 19:59:06ronaldoussorenlinkissue14455 messages
2013-11-19 19:59:06ronaldoussorencreate