Author pitrou
Recipients barry, ethan.furman, ncoghlan, paul.moore, pitrou, r.david.murray
Date 2013-10-24.09:19:21
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1382606361.4.0.935026630203.issue19331@psf.upfronthosting.co.za>
In-reply-to
Content
> In cases where inheritance is not encouraged and it is judged to improve
> readability at the point of use, the naming convention for callables
> (lower_case_with_underscores) may be used instead. This is an indication
> that the type is intended primarily for use "as is", rather than through
> inheritance (although subclassing is still permitted).

I don't think this wording is appropriate.

As soon as the "thing" is documented as a *type* (i.e. something you call to get instances that have a specific interface - methods, etc.), then IMO it should follow the naming scheme for classes.
Only when the "thing" is not documented as a type but as a convenience callable (for example a context manager) is it reasonable to follow the naming scheme for functions.

In other words, this has nothing to do with subclassing.
History
Date User Action Args
2013-10-24 09:19:21pitrousetrecipients: + pitrou, barry, paul.moore, ncoghlan, r.david.murray, ethan.furman
2013-10-24 09:19:21pitrousetmessageid: <1382606361.4.0.935026630203.issue19331@psf.upfronthosting.co.za>
2013-10-24 09:19:21pitroulinkissue19331 messages
2013-10-24 09:19:21pitroucreate